[Open SoC Debug] Queries Regarding GSoC and Open SoC

Philipp Wagner philipp.wagner at tum.de
Wed Feb 28 18:14:47 CET 2018


On 02/28/2018 06:03 PM, Anant Sharma wrote:
> I have the sourcing of optimsoc-environment.sh included in my ~\.bashrc
> 
> Still didn't work. I kind of have a feeling that it is something to do 
> with changing the variable $FUSESOC_CORES. But I had concatenated the 
> directory of the examples of optimsoc rather than change what it already 
> had.

Please run the following commands and send the full output (or even 
better, place it on pastebin.com)

echo $OPTIMSOC
echo $OPTIMSOC_SOURCE
ls -l $OPTIMSOC
ls -l $OPTIMSOC_SOURCE
fusesoc --cores-root $OPTIMSOC_SOURCE/examples sim --build-only 
optimsoc:examples:compute_tile_sim

Two more things:
- Please configure your email client to send text-only emails to mailing 
lists.
- Please don't top-post; it makes it very hard to understand the context 
of the message. Instead (as shown in this response) reply below the text 
you're referring to. You can find examples and more discussion e.g. 
here: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

Best,

Philipp


> On Wed, Feb 28, 2018 at 10:19 PM, Philipp Wagner <philipp.wagner at tum.de 
> <mailto:philipp.wagner at tum.de>> wrote:
> 
>     On 02/28/2018 04:29 PM, Anant Sharma wrote:
> 
>         Done some changes around the same and getting a different error
>         which is attached in the log file below. Would be great if
>         someone could help out!
> 
> 
>     How did you run the simulation? It seems like you did some
>     modifications to the sources and broke the include path?
> 
>     Please try again with the instructions I just sent and make sure you
>     don't modify any of the sources (yet).
> 
>     Philipp
> 
> 




More information about the OpenSoCDebug mailing list